+  HandyCache форум
|-+  Гостевая» Гостевая» Проблема с HTTP 1.0
Имя пользователя:
Пароль:
Страниц: [1]   Вниз
  Ответ    Отправить эту тему    Печать  
Автор Тема: Проблема с HTTP 1.0  (Прочитано 8074 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Out-user
Гость
« : 08 июня 2007, 21:39:12 »
ПроцитироватьЦитировать

Проблема с загрузкой PHP. При попытке зайти на PHP страничку появляется сообщение:
"Не удаётся загрузить / с ...

Не удаётся открыть этот узел Интернета. Узел недоступен или не найден. Повторите попытку позже."

Без HC страница грузится без вопросов. Возможно я что-то напутал с правилами:
                                       
Запись в кеш:
Правило:    (.)*
Исключение:    \.(exe|ini|dll|mds|mdf|dat|iso|doc|txt|waw|ogg|pdf|mp3|
com|arj|rar|zip|7z|cab|mp3|avi)$

Только из кеша:
Включены все стандартные, плюс:  (.)*\.(css|is)

Остальные списки по умолчанию.
Сообщить модератору   Записан
DenZzz
Модератор
*****

Репутация: +179/-11
Offline Offline

Сообщений: 5589



« Ответ #1 : 08 июня 2007, 21:43:47 »
ПроцитироватьЦитировать

Проблема с загрузкой PHP. При попытке зайти на PHP страничку появляется сообщение:
"Не удаётся загрузить / с ...

Не удаётся открыть этот узел Интернета. Узел недоступен или не найден. Повторите попытку позже."

Что видишь в Мониторе HC в поле "Ответ" и "Правило"?
Сообщить модератору   Записан
Out-user
Гость
« Ответ #2 : 09 июня 2007, 10:15:21 »
ПроцитироватьЦитировать

Ответ:
200 OK gzip

Правило:
3.4 (Запись в кеш): (.)*
Сообщить модератору   Записан
DenZzz
Модератор
*****

Репутация: +179/-11
Offline Offline

Сообщений: 5589



« Ответ #3 : 09 июня 2007, 11:09:32 »
ПроцитироватьЦитировать

Ответ:
200 OK gzip

Так это удачная загрузка или неудачная? Когда "Узел недоступен или не найден" должно быть что-то вроде "404 Not Found"...
Приложи полный лог Монитора! Через HC вообще не заходит или только временами проблемы?

Цитировать
Только из кеша:
Включены все стандартные, плюс:  (.)*\.(css|is)

А вот это ты зря добавил css и js в "Только из кэша"! Без скриптов могут быть проблемы на многих сайтах, а без стилей внешний вид сильно страдает!
Сообщить модератору   Записан
Out-user
Гость
« Ответ #4 : 10 июня 2007, 11:36:17 »
ПроцитироватьЦитировать

Проблемы только с определёнными сайтами, я бы даже сказал страничками. В основном это форумы (PHP), но не только.
Например, такая же проблема при попытке зайти на http:/handycache.ru/ (так как не зарегиным пользователям нельзя писать ссылки, то пришлось записать в ссылке вместо // одну / ). Кстати, регистрация на форуме у меня не работает (даже без HC).

В мониторе:
URL: http:/handycache.ru/
Размер: (пустая графа)
Получено: 8444
%: (пустая строка)
Состояние: (стоит галочка)
Ответ: 200 OK gzip
Правила: 3.4 (Запись в Кеш): (.)*

При попытке зайти на http:/handycache.ru/ также выдаёт такой лог:

10.06.2007 10:33:48 # 37: Connection from local/127.0.0.1

10.06.2007 10:33:48 # 37 >>> URL: http:/handycache.ru/
GET http:/handycache.ru/ HTTP/1.0
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
Accept-Language: ru
Cookie: PHPSESSID=54b7811cec6290b64e04c7b8d4f18b44; dfaf8b958d32999e00affd4aedd4f5b1=dbbff4d8cb55ec5e077536398215e66c
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; Maxthon; .NET CLR 2.0.50727)
If-Modified-Since: Sun, 10 Jun 2007 06:31:56 GMT
Accept-Encoding: gzip, deflate
Host: handycache.ru
Proxy-Connection: Keep-Alive


10.06.2007 10:33:48 # 37: DNS resolve handycache.ru --> 217.112.42.114

10.06.2007 10:33:48 # 37:  Outbound Connection

10.06.2007 10:33:55 # 37 <<< URL: http:/handycache.ru/
HTTP/1.1 200 OK
Date: Sun, 10 Jun 2007 06:34:21 GMT
Server: Apache/1.3.33 (Unix) mod_fastcgi/2.4.0 FrontPage/5.0.2.2623 PHP/4.3.10 mod_gzip/1.3.19.1a mod_ssl/2.8.22 OpenSSL/0.9.7b rus/PL30.20
X-Powered-By: PHP/4.3.10
Expires: Mon, 26 Jul 1997 05:00:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Content-Encoding: gzip
Last-Modified: Sun, 10 Jun 2007 06:34:21 GMT
Cache-Control: post-check=0, pre-check=0
Connection: close
Content-Type: text/html


10.06.2007 10:33:55 # 37:  Outbound Disconnection

10.06.2007 10:33:55 # 37:  Client Disconnection


Насчёт css и js всё конечно правильно, я сам занимался web-дизайном и web-программированием, поэтому на себе ощутил важность этих элементов. Но, т.к. я захожу в основном только на узкий круг сайтов, где всё заранее прокешировал, то правило вполне приемлемо. Конечно, правильнее было создать отдельные правила для часто посещаемых сайтов, но пока руки не доходят Подмигивающий

Браузер: Maxthon 1.5.9
HC: 0.98b1
Сообщить модератору   Записан
DenZzz
Модератор
*****

Репутация: +179/-11
Offline Offline

Сообщений: 5589



« Ответ #5 : 10 июня 2007, 12:53:58 »
ПроцитироватьЦитировать


Попробуй включить в браузере HTTP/1.1 , возможно, причина в этом... Как это сделать, сказано в ФАКе.

P.S. На будущее - пользуйся в Мониторе контекстной командой "Копировать строку Монитора" или "Сохранять содержимое монитора" в настройках, когда просят лог Монитора!
Сообщить модератору   Записан
Out-user
Гость
« Ответ #6 : 10 июня 2007, 13:40:52 »
ПроцитироватьЦитировать

Большое спасибо, проблема была в этом.

Про лог понял, так и буду делать  Подмигивающий
Сообщить модератору   Записан
Страниц: [1]   Вверх
  Ответ    Отправить эту тему    Печать  

 
Перейти в:  

+ Быстрый ответ
С быстрым ответом Вы также можете использовать BB код и смайлы.